EXCEL PLUGIN

Download Excel Plugin

Download

Troubleshooting

.net Framework required: Ver 4.0 - Download Link

VSTO Runtime (Only required for Office 2007 users) - Download link

Support Office : Supported Version of Excel plugin: Office 2007/ office 2010

Support OS : Supported Operating system: XP with SP3/Win7/Win8/Win10